Performance across the Phreesia Dashboard and SSO login has returned to normal and all systems are operational.
Posted Jun 17, 2026 - 12:02 EDT
Monitoring
We are no longer seeing issues with navigation in the Phreesia Dashboard. At this time, we are monitoring some performance issues related to SSO login. We will provide updates as more information becomes available.
Posted Jun 17, 2026 - 11:36 EDT
Investigating
We are currently investigating an issue that may be causing some users to experience difficulty logging into Dashboard and/or navigating within Dashboard.
Engineering is actively investigating. We will provide updates as more information becomes available.
Posted Jun 17, 2026 - 11:00 EDT
This incident affected: Zone 1 (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard), Zone 2 (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard), EAP (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard), Zone 3 (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard), Zone 4 (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard), and Zone 5 (Phreesia Dashboard, Single Sign-On to Phreesia Dashboard).