Issue with Phone Provider
Incident Report for Phreesia
Resolved
Our vendor has resolved the issue with inbound and outbound calls, and our Technical Support team is available to assist you via phone.

Issue Start: 9:51am ET
Issue End: 10:32am ET
Posted Jul 14, 2023 - 10:34 EDT
Identified
Our Technical Support team is currently experiencing issues with our phone provider for inbound and outbound calls. As we work with our provider to resolve the issue, please reach out to support@phreesia.com or go to the support portal through your Phreesia dashboard to log any inquiries you may have.
Posted Jul 14, 2023 - 10:24 EDT
This incident affected: Phreesia Products (Phone System).