Cloudflare Service Disruption

Incident Report for Phreesia

Resolved

System performance has remained stable following Cloudflare’s remediation efforts. All affected services — including PhreesiaOnCall/VoiceAI (Daytime and After Hours), Appointment Accelerator, Payment Services (manual card entry and card swipe), and eClinicalWorks (eCW) integrations — are now fully operational.

Thank you for your patience while this issue was resolved.
Posted Nov 18, 2025 - 12:20 EST

Monitoring

We are now seeing performance return to normal across impacted services, including PhreesiaOnCall/VoiceAI (Daytime and After Hours), Appointment Accelerator, Payment Services (manual card entry and card swipe), and our ability to integrate with the eClinicalWorks (eCW) EHR.

We will continue to monitor system performance closely to ensure full stability. If any further issues arise, we will provide additional updates.
Posted Nov 18, 2025 - 10:21 EST

Identified

Cloudflare has deployed a change and we are seeing gradual recovery to the affected components. We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Nov 18, 2025 - 09:47 EST

Update

Cloudflare continues to work on restoring their services. We continue to see issues affecting PhreesiaOnCall/VoiceAI (Daytime and After hours), Appointment Accelerator, and Payment Services (particularly manual card entry and card swipe transactions).

In addition, this issue is affecting our ability to integrate to clients with eClinicalWorks (eCW) EHR.

We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Nov 18, 2025 - 09:11 EST

Investigating

Our third-party provider, Cloudflare, is having an ongoing incident and is actively investigating the root cause. We are currently experiencing intermittent issues affecting PhreesiaOnCall/VoiceAI (Daytime and After hours), Appointment Accelerator, and Payment Services (particularly manual card entry and card swipe transactions).

We are seeing gradual improvements, but the situation remains unstable at this time. We will continue to monitor the situation closely and provide updates as more information becomes available.
Posted Nov 18, 2025 - 07:43 EST
This incident affected: Phreesia Products (Appointment Accelerator), VoiceAI (VoiceAI Dashboard, Patient Phone Communication, Calltree / Greetings), Zone 4 (Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 5 (Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 1 (Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 2 (Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 3 (Payment Services - Phreesia Processor, Payment Services - Gateway), and EAP (Payment Services - Phreesia Processor, Payment Services - Gateway).