Dashboard Delays on Zone 3
Incident Report for Phreesia
Resolved
Resolved - We apologize for the interruption; this notification was sent to Zone 3 clients in error. The Phreesia Dashboard on Zone 3 is not experiencing any delays.

We apologize for this inconvenience.
Posted Nov 14, 2022 - 10:38 EST
Investigating
Investigating - Our engineering team is currently investigating reports of delays when utilizing the Phreesia Dashboard.

All Clients
Zone 1

Please check back at this page for additional updates.
Posted Nov 14, 2022 - 10:24 EST
This incident affected: Zone 3 (Phreesia Dashboard).