We are no longer receiving reports of slowness while navigating the Phreesia Dashboard or completing intake forms.
Performance has remained stable, and Phreesia systems and infrastructure continue to operate normally.
Posted Jun 11, 2026 - 19:11 EDT
Monitoring
We continue to monitor reports from some users experiencing slowness while navigating the Phreesia Dashboard and completing intake forms.
Network conditions that may have been contributing to the issue improved overnight, and monitoring indicates performance has remained stable. We also received information indicating that a major regional internet connectivity issue impacted parts of the West Coast during the same timeframe, which aligns with the limited client impact observed.
Phreesia systems and infrastructure continued to operate normally, and this does not appear to have been a widespread Phreesia platform issue.
Posted Jun 11, 2026 - 09:32 EDT
Update
We are continuing to investigate reports from some users experiencing slowness while navigating the Phreesia dashboard and completing intake forms.
At this time, monitoring indicates error rates have decreased from earlier elevated levels. Some users may also be seeing improved performance, and reports of issues have slowed.
Current information continues to indicate the issue is related to regional ISP/network routing degradation impacting a limited number of clients on the West Coast and is not a widespread Phreesia platform issue. Phreesia systems and infrastructure continue to operate normally. We will continue to monitor network conditions, internal error trends, and user reports through the morning as normal traffic volumes return to validate that performance remains stable. We will provide another update as additional information becomes available.
Posted Jun 10, 2026 - 19:37 EDT
Investigating
We are aware of reports from some users experiencing slowness while navigating the Phreesia dashboard and completing intake forms. Our investigation indicates this is related to regional ISP/network routing degradation and is not a widespread platform issue.
The issue is limited to users in certain geographic regions, primarily on the West Coast. Phreesia systems and infrastructure are operating normally. We are monitoring network conditions and tracking affected routes.
We will provide an update as additional information becomes available.
Posted Jun 10, 2026 - 16:18 EDT
This incident affected: Zone 1 (Phreesia Dashboard, PhreesiaPads), Zone 2 (Phreesia Dashboard, PhreesiaPads), EAP (Phreesia Dashboard, PhreesiaPads), Zone 3 (Phreesia Dashboard, PhreesiaPads), Zone 4 (Phreesia Dashboard, PhreesiaPads), and Zone 5 (Phreesia Dashboard, PhreesiaPads).