Vantiv/Worldpay Service Disruption - Issues processing payments
Incident Report for Phreesia
Resolved
Our payment processing vendor, Vantiv/Worldpay, experienced a service disruption this afternoon. You may have experienced payments failing to process during this time.

Issue Start: 1:07 PM EDT
Issue End: 1:29 PM EDT

Please contact our support line at 888-654-7473 if you are still experiencing issues.
Posted Nov 01, 2022 - 13:30 EDT