Zone 2 Eligibility & Benefits Delays
Incident Report for Phreesia
Resolved
Resolved - We continue to see normal performance across the Phreesia platform. We will be marking this incident as resolved. 

Issue Start: 6:55 AM ET 
Issue End: 9:57 AM ET 

We apologize for the inconvenience this caused your practice.
Posted May 24, 2023 - 13:50 EDT
Monitoring
Monitoring - Our engineering team has resolved the issues with Eligibility and Benefits not returning results for insurance checks as well as delays with updating the copay column. We will continue to monitor performance prior to closing this incident. 

We apologize for the inconvenience this caused your practice.
Posted May 24, 2023 - 10:06 EDT
Investigating
Investigating - Our engineering team is currently investigating reports of Eligibility & Benefits not returning results for insurance checks as well as delays with updating the copay column on the Dashboard.

All clients
Zone 2

Please check back at this page for additional updates.
Posted May 24, 2023 - 08:57 EDT
This incident affected: Zone 2 (Eligibility and Benefits Verification).