Spectrum ISP Customers Experiencing Dashboard Access Issues
Incident Report for Phreesia
Resolved
Resolved - We no longer see issues with customers using Spectrum ISP being unable to login to the Dashboard.

If you continue to experience issues, please reach out to our support team at 888-654-7473.
Posted Nov 23, 2022 - 09:34 EST
Investigating
Investigating - Our team is currently investigating reports of end users being unable to access the Phreesia Dashboard with the Spectrum ISP.

Some Clients
All Zones

Please check back at this page for additional updates.
Posted Nov 22, 2022 - 10:30 EST
This incident affected: Zone 1 (Phreesia Dashboard), Zone 2 (Phreesia Dashboard), EAP (Phreesia Dashboard), Zone 3 (Phreesia Dashboard), and Zone 4 (Phreesia Dashboard).