AWS Incident Impacting Phreesia Services

Incident Report for Phreesia

Resolved

All Phreesia services, including Payments, Mobile SMS, and our Support phone service, are now fully operational. SMS message queues have cleared with no remaining delays, and our Engineering team has confirmed full recovery as AWS systems stabilized.

We apologize for any inconvenience this may have caused and appreciate your patience as services recovered.

If you have any questions or concerns, please contact Phreesia Support at support@phreesia.com.
Posted Oct 20, 2025 - 20:53 EDT

Monitoring

We are seeing improvements across our Payments platform, Mobile SMS and Support phone service following the earlier AWS disruption. Payments are processing successfully, and our Support line is operational.

We may continue to see slight delays with SMS-based services as systems continue to recover. Our team is closely monitoring all services and will provide updates as they come.

If you have any questions or concerns, please contact Phreesia Support at support@phreesia.com.

Additional information:

AWS has been experiencing an incident that has been causing disruptions to some of Phreesia’s services. This AWS incident is impacting organizations across the country. We want to provide some additional details about the AWS incident and how it may impact your Phreesia services:

- Starting early October 20, 2025, AWS has been reporting elevated error rates and latency in multiple service components.
- The disruption has impacted a large number of downstream applications and services globally, from banking services to social networks to online booking sites, indicating that many platforms reliant on AWS’s shared infrastructure are being affected.
- Some of our service partners have also been impacted by this AWS issue, which may contribute to continued intermittent performance in certain Phreesia services.

For the most recent updates on this incident and subsequent disruptions, please follow the AWS status page directly: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 17:41 EDT

Update

We are continuing to work on a fix for this issue.
Posted Oct 20, 2025 - 15:57 EDT

Update

We are seeing issues with payment processing resurface after a brief period of stability. These disruptions continue to stem from ongoing AWS service instability.

Our engineering team remains actively engaged and is monitoring the situation closely. We’ll provide updates as more information becomes available.
Posted Oct 20, 2025 - 15:15 EDT

Update

We are seeing improvements in performance with our Payments platform as payments are being taken successfully. Our team is monitoring to ensure continued stability. However, we are still seeing intermittent issues with mobile SMS and our Support phone services due to the broader AWS incident.

Our engineering team remains actively engaged and will provide updates as more information becomes available. We apologize for any inconvenience this may cause.
Posted Oct 20, 2025 - 15:01 EDT

Update

Our team continues to actively investigate the ongoing issues related to AWS that are impacting Payments, Mobile SMS, and our Support phone line. We are closely monitoring the situation and will continue to share additional updates as AWS works toward recovery.

Please note that our main Support phone line remains affected; for assistance, contact Support@phreesia.com.
Posted Oct 20, 2025 - 13:20 EDT

Identified

We’re seeing issues return with AWS, which are currently impacting Payments, Mobile SMS, and our Support phone line. Our team is actively investigating and will provide updates as they become available.

Please note that our main Support phone line is affected; for assistance, contact support@phreesia.com.
Posted Oct 20, 2025 - 10:30 EDT

Monitoring

We are seeing a return to normal performance for all our services. We will continue to monitor before marking the issue as resolved.

If you have any questions or concerns do not hesitate to contact Phreesia Support at support@phreesia.com or by at phone at 1-888-654-7473
Posted Oct 20, 2025 - 08:58 EDT

Update

We are seeing improvements with performance against the impacted Phreesia services. We may continue to see slight delays with SMS based services as systems continue to recover. We will provide another update shortly.

The Phreesia Support phone line is fully operational now.
Posted Oct 20, 2025 - 08:36 EDT

Identified

Amazon Web Services is currently recovering from an incident affecting multiple services across the internet. We continue see some Phreesia services impacted as a result. We continue to monitor and will provide updates as services recover.

Please note - this is impacting our main Support phone line. Please contact support@phreesia.com if you have any questions.

We apologize for any inconvenience this may cause.
Posted Oct 20, 2025 - 06:26 EDT
This incident affected: PhreesiaOnCall (PhreesiaOnCall), Phreesia Products (Phone System), Zone 4 (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 5 (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 1 (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 2 (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway), Zone 3 (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway), and EAP (Mobile - SMS, Patient Chat, Payment Services - Phreesia Processor, Payment Services - Gateway).