Zone 3 Dashboard Issues

Incident Report for Phreesia

Resolved

This incident has been resolved.
Posted Jun 04, 2026 - 09:30 EDT

Monitoring

The issue affecting the Zone 3 Dashboard has been resolved, and the Dashboard is now displaying as expected for users in Zone 3. Engineering will continue to monitor and provide additional updates if needed.
Posted Jun 04, 2026 - 08:18 EDT

Investigating

We are currently investigating an issue affecting the Zone 3 Dashboard. This issue may be causing issues with the completion of some actions in the Dashboard.

Engineering is actively investigating. We will provide updates as more information becomes available.
Posted Jun 04, 2026 - 08:07 EDT
This incident affected: Zone 3 (Phreesia Dashboard).