Import delays on Zone 4

Incident Report for Phreesia

Resolved

Appointment imports to the Phreesia Dashboard are processing as expected, and workflow performance remains stable. We apologize for any inconvenience this may have caused.
Posted May 28, 2025 - 17:00 EDT

Monitoring

Appointment imports to the Phreesia Dashboard are now processing as expected. Workflow performance has returned to normal, with no delays when loading or navigating patient workflows. We will continue to monitor to ensure stable performance.
Posted May 28, 2025 - 13:50 EDT

Investigating

Our Engineering team is currently investigating reports of delays with appointments importing into the Phreesia Dashboard. This issue is also impacting patients who may experience delays when loading or navigating through their workflow.
Posted May 28, 2025 - 09:56 EDT
This incident affected: Zone 4 (Phreesia Dashboard, Import Functions).