Issue with Phone Provider
Incident Report for Phreesia
Resolved
Our vendor has resolved the issue with inbound and outbound calls, and our Technical Support team is available to assist you via phone.

Issue Start: 4:17pm ET
Issue End: 5:08pm ET
Posted Jun 14, 2023 - 17:17 EDT
Identified
Hello,

Our Technical Support team is currently experiencing issues with our phone provider for inbound and outbound calls. Wait times reaching our Technical Support team may be longer than usual. In the meantime please use support@phreesia.com or go to the support portal through your Phreesia dashboard to log any issues you may be having.

Please check back on this page for updates.
Posted Jun 14, 2023 - 16:44 EDT
This incident affected: Phreesia Products (Phone System).