Zone 5 Insurance and Copay Issues

Incident Report for Phreesia

Resolved

The insurance and copay issue affecting new visits on the Dashboard has been resolved and information is now displaying as expected.
Posted May 07, 2026 - 14:23 EDT

Identified

The issue has been identified, and our team is making progress towards a full recovery. We’re working through a backlog of messages and appreciate your patience.
Posted May 07, 2026 - 10:30 EDT

Investigating

We are currently investigating an issue that is causing insurance and copays to not be tied to new visits on the Dashboard. Our Engineering team is actively investigating, and we will provide updates as more information becomes available.
Posted May 07, 2026 - 09:15 EDT
This incident affected: Zone 5 (Eligibility and Benefits Verification).